78298 Absturz

hier kommen Threads hinein, nachdem eine Meldung bearbeitet wurde
Antworten
Benutzeravatar
Dennis0078
Vizeadmiral
Vizeadmiral
Beiträge: 2051
Registriert: Samstag 6. Dezember 2008, 21:05

78298 Absturz

Beitrag von Dennis0078 » Freitag 25. Januar 2013, 20:15

hier wieder ein Absturz.
kam nach Runde beenden/ nach Kampf

Spiel 78298
TrBotE_r78302.exe

Omega Allianz
Dateianhänge
a2auto.sav
(233.77 KiB) 77-mal heruntergeladen

Benutzeravatar
Sir Pustekuchen
Administrator
Administrator
Beiträge: 4181
Registriert: Dienstag 10. Januar 2006, 16:46
Kontaktdaten:

Re: 78298 Absturz

Beitrag von Sir Pustekuchen » Samstag 26. Januar 2013, 00:30

Dein Save lässt sich nicht laden...

Andi47
Kapitän
Kapitän
Beiträge: 429
Registriert: Samstag 25. Juni 2011, 10:47

Re: 78298 Absturz

Beitrag von Andi47 » Samstag 26. Januar 2013, 07:01

Sir Pustekuchen hat geschrieben:Dein Save lässt sich nicht laden...
Bug bei der Erstellung der Autosaves?

Benutzeravatar
Dennis0078
Vizeadmiral
Vizeadmiral
Beiträge: 2051
Registriert: Samstag 6. Dezember 2008, 21:05

Re: 78298 Absturz

Beitrag von Dennis0078 » Samstag 26. Januar 2013, 07:30

Das muss auch mit den Absturz zusammenhängen.
hier wäre noch ein Autosave der Runde zuvor.
scheint sich aber nicht zu wiederholen.

könnte man nicht auch
autolog1.log
autolog2.log
autolog3.log
abspeichern?
Ich hatte den Save schon geladen und dann wurde das log schon überschrieben.
Dateianhänge
a1auto2.sav
(235.28 KiB) 69-mal heruntergeladen

Benutzeravatar
Sir Pustekuchen
Administrator
Administrator
Beiträge: 4181
Registriert: Dienstag 10. Januar 2006, 16:46
Kontaktdaten:

Re: 78298 Absturz

Beitrag von Sir Pustekuchen » Samstag 26. Januar 2013, 09:55

Vielleicht ein nicht reproduzierbarer Absturz während des Speicherns. Ich kann es auf jedenfall nicht nachstellen, somit auch nicht fixen. Ich markiere es mal als NO_BUG, damit ich weiß, die Meldung ist abgearbeitet.

Benutzeravatar
Dennis0078
Vizeadmiral
Vizeadmiral
Beiträge: 2051
Registriert: Samstag 6. Dezember 2008, 21:05

Re: [NO_BUG] 78298 Absturz

Beitrag von Dennis0078 » Samstag 26. Januar 2013, 18:15

und nochmal während Kampfberechnung.

diesmal hab ich ein log.
lässt sich mit autsave nicht wiederholen.
Dateianhänge
BotEomegaallianz.zip
(128.12 KiB) 71-mal heruntergeladen

Benutzeravatar
rainer
Vizeadmiral
Vizeadmiral
Beiträge: 2897
Registriert: Mittwoch 12. September 2007, 10:57

Re: 78298 Absturz

Beitrag von rainer » Samstag 26. Januar 2013, 21:51

habe den Thread ins Archiv geschoben, allerdings auch das NO BUG entfernt. Wenn der Fehler wieder/immer noch auftritt, dann existiert er.
Ob Puste den letzten Post (aufgrund NO BUG) gelesen hat, weiß ich nicht. Die log bricht ab nach
INFO general Server is sending NextRoundData to client...
INFO general ... serialization of NextRoundData succesfull
INFO general Client is receiving NextRoundData from server...
INFO general ... serialization of NextRoundData succesfull
nächster LOG-Eintrag wäre (siehe Runde vorher)
INFO general Getting Message to UpdateViews...


als ich den Stand geladen habe, kam als erstes: Neues Alienartefakt gefunden

vll. existiert ein Problem, wenn die EventsScreens aufgerufen/verteilt werden. Das würde m.Erachtens zur Beschreibung von Dennis passen (und ist nur schwer nachzustellen/zu debuggen)

wenn das Problem noch existiert, wird es ja immer wieder hochkommen :wink:

Benutzeravatar
Sir Pustekuchen
Administrator
Administrator
Beiträge: 4181
Registriert: Dienstag 10. Januar 2006, 16:46
Kontaktdaten:

Re: 78298 Absturz

Beitrag von Sir Pustekuchen » Samstag 26. Januar 2013, 22:22

Ja, das kann dann immer wieder mal passieren. Lässt sich aber nur schwer nachvollziehen. Da müssten wir auf die Crush-Dumps zurückgreifen. Ist dann aber ne schwierigere Angelegenheit zu erklären wie man das macht. Ich hatte aber während des Testens keine Abstürze seit ca. 7 Tagen und ich lasse mehrmals am Tag autoturn=200 durchlaufen...

Anonymissimus
Flottenkapitän
Flottenkapitän
Beiträge: 990
Registriert: Freitag 14. Mai 2010, 14:39

Re: 78298 Absturz

Beitrag von Anonymissimus » Samstag 26. Januar 2013, 22:34

Sir Pustekuchen hat geschrieben:Ich hatte aber während des Testens keine Abstürze seit ca. 7 Tagen und ich lasse mehrmals am Tag autoturn=200 durchlaufen...
Die Aussagekraft stabiler autoturn Tests ist leider recht begrenzt. Es gibt halt viel code (in der UI, userinteraktion) der davon unabhängig ist und einiges anders macht. Dadurch kommt es am ehesten noch zu Abstürzen und Fehlern.
Man kann aber sagen, dass stabile autoturn Tests notwendig sind.

Benutzeravatar
Dennis0078
Vizeadmiral
Vizeadmiral
Beiträge: 2051
Registriert: Samstag 6. Dezember 2008, 21:05

Re: 78298 Absturz

Beitrag von Dennis0078 » Samstag 26. Januar 2013, 22:37

ich glaube an den Event liegt es nicht,
Vielleicht wird manchmal zu viel Arbeitsspeicher bei der Kampfberechnung verbraucht, und dann stürzt es ab.

Benutzeravatar
Sir Pustekuchen
Administrator
Administrator
Beiträge: 4181
Registriert: Dienstag 10. Januar 2006, 16:46
Kontaktdaten:

Re: 78298 Absturz

Beitrag von Sir Pustekuchen » Samstag 26. Januar 2013, 22:44

Dann hätte das der Autotest gemerkt. Arbeitsspeicher sollte bei BotE kein Problem sein. Ich glaube mehr als maximal 200MB brauchen wir nicht.

Benutzeravatar
rainer
Vizeadmiral
Vizeadmiral
Beiträge: 2897
Registriert: Mittwoch 12. September 2007, 10:57

Re: 78298 Absturz

Beitrag von rainer » Samstag 26. Januar 2013, 22:55

ja, Arbeitsspeicher wohl kaum...diese Diskussion hatten wir schonmal :roll:

Antworten

Zurück zu „Archiv Bug-Meldungen aus BotE-Testversionen“